swift_composer 0.2.0
swift_composer: ^0.2.0 copied to clipboard

Extensible Object Manager with no boilerplate code using source_gen

0
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: Documenting swift_composer...
Initialized dartdoc with 670 libraries in 59.7 seconds
Generating docs for library swift_composer from package:swift_composer/swift_composer.dart...
Generating docs for library swift_composer from package:swift_composer/swift_generator.dart...
Documented 2 public libraries in 1.2 seconds
stderr:   warning: swift_composer has no library level documentation comments, from swift_composer: (file:///tmp/pub-dartlang-dartdocAMYKXR/pkg/lib/swift_composer.dart:1:9)
  warning: swift_composer has no library level documentation comments, from swift_composer: (file:///tmp/pub-dartlang-dartdocAMYKXR/pkg/lib/swift_generator.dart:1:9)
  error: failed to write file at: swift_composer/swift_composer-library.html
    for symbol swift_composer: (file:///tmp/pub-dartlang-dartdocAMYKXR/pkg/lib/swift_generator.dart:1:9)
    conflicting with file already generated by swift_composer: (file:///tmp/pub-dartlang-dartdocAMYKXR/pkg/lib/swift_composer.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            swift_composer conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 2 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:247:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:22:19)
<asynchronous suspension>

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/swift_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.40.39.171.7.1
build^1.2.21.6.22.0.2
build_config^0.4.1+10.4.71.0.0
path^1.6.41.8.01.8.0
source_gen^0.9.40.9.10+21.0.2
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.022.0.0
args-1.6.02.1.1
async-2.7.02.7.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.1
file-5.2.16.1.2
glob-1.2.02.0.1
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
logging-1.0.11.0.1
meta-1.4.01.4.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
pedantic-1.11.11.11.1
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.39.4` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

0
likes
80
pub points
0%
popularity

Publisher

swift.shop

Extensible Object Manager with no boilerplate code using source_gen

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_config, path, source_gen, yaml

More

Packages that depend on swift_composer