stream_feed_flutter_core 0.8.0 copy "stream_feed_flutter_core: ^0.8.0" to clipboard
stream_feed_flutter_core: ^0.8.0 copied to clipboard

Stream Feed official Flutter SDK Core. Build your own feed experience using Dart and Flutter.

12
likes
130/ 160
pub points
83%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/GetStream/stream-feed-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

820 out of 992 API elements (82.7 %) have documentation comments.

Some symbols that are missing documentation: stream_feed_flutter_core, stream_feed_flutter_core.AggregatedFeed.getPaginatedActivities, stream_feed_flutter_core.AggregatedFeed.subscriber, stream_feed_flutter_core.Attachment.Attachment.fromJson, stream_feed_flutter_core.Attachment.Attachment.fromMedia.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:stream_feed_flutter_core/stream_feed_flutter_core.dart that imports:
  • package:stream_feed_flutter_core/src/upload_list_core.dart that imports:
  • package:stream_feed_flutter_core/src/typedefs.dart that imports:
  • package:stream_feed_flutter_core/src/reactions_list_core.dart that imports:
  • package:stream_feed_flutter_core/src/bloc/bloc.dart that imports:
  • package:stream_feed_flutter_core/src/bloc/provider.dart that imports:
  • package:stream_feed_flutter_core/src/bloc/feed_bloc.dart that imports:
  • package:stream_feed_flutter_core/src/upload/upload_controller.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/extensions.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.1 4.0.6 5.4.3+1
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.12.0 1.15.0
rxdart ^0.27.1 0.27.7 0.28.0
stream_feed ^0.6.0+2 0.6.0+2 0.6.0+2
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
crypto_keys - 0.3.0+1 0.3.0+1
faye_dart - 0.1.1+2 0.1.1+2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
jose - 0.3.4 0.3.4
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
x509 - 0.2.4+2 0.2.4+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.1` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^0.27.1` on rxdart does not support the stable version `0.28.0`, that was published 0 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

12
likes
130
pub points
83%
popularity

Publisher

verified publishergetstream.io

Stream Feed official Flutter SDK Core. Build your own feed experience using Dart and Flutter.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

unknown (LICENSE)

Dependencies

dio, equatable, flutter, meta, rxdart, stream_feed

More

Packages that depend on stream_feed_flutter_core