stream_feed 0.6.0+2 copy "stream_feed: ^0.6.0+2" to clipboard
stream_feed: ^0.6.0+2 copied to clipboard

Stream Feed official Dart SDK. Build your own feed experience using Dart and Flutter.

19
likes
120/ 160
pub points
81%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

625 out of 686 API elements (91.1 %) have documentation comments.

Some symbols that are missing documentation: stream_feed, stream_feed.AggregatedFeed.getPaginatedActivities, stream_feed.AggregatedFeed.subscriber, stream_feed.Content.toJson, stream_feed.FlatFeed.subscriber.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: StreamAnalytics.userData

lib/src/client/analytics_client.dart:19:7

   ╷
19 │ class StreamAnalytics extends Equatable {
   │       ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client/analytics_client.dart

WARNING: Doc directive 'image' is unknown.

lib/src/client/personalization_client.dart:13:7

   ╷
13 │ /// {@image <image alt='' src='https://getstream.imgix.net/images/docs/personalization5cases@2x.png?cs=strip&auto=format,compress?auto=compress,auto&fit=clip&h=600&w=800'>}
   │       ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client/personalization_client.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
dio ^4.0.0 4.0.6 5.4.3+1
equatable ^2.0.0 2.0.5 2.0.5
faye_dart ^0.1.1+2 0.1.1+2 0.1.1+2
http_parser ^4.0.0 4.0.2 4.0.2
intl ^0.17.0 0.17.0 0.19.0
jose ^0.3.2 0.3.4 0.3.4
json_annotation ^4.4.0 4.9.0 4.9.0
logging ^1.0.1 1.2.0 1.2.0
meta ^1.3.0 1.15.0 1.15.0
mime ^1.0.0 1.0.5 1.0.5
Transitive dependencies
Package Constraint Compatible Latest
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
crypto_keys - 0.3.0+1 0.3.0+1
http - 1.2.1 1.2.1
js - 0.7.1 0.7.1
matcher - 0.12.16+1 0.12.16+1
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
x509 - 0.2.4+2 0.2.4+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

19
likes
120
pub points
81%
popularity

Publisher

verified publishergetstream.io

Stream Feed official Dart SDK. Build your own feed experience using Dart and Flutter.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

unknown (LICENSE)

Dependencies

collection, dio, equatable, faye_dart, http_parser, intl, jose, json_annotation, logging, meta, mime

More

Packages that depend on stream_feed