sqflite_entities_generator 0.0.3 copy "sqflite_entities_generator: ^0.0.3" to clipboard
sqflite_entities_generator: ^0.0.3 copied to clipboard

sqflite entities generator used for sql_entities packages, see more details on https://github.com/guid-empty/sqflite_entities

0
likes
40/ 140
pub points
6%
popularity

We analyzed this package 37 hours ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
Because sqflite_entities_generator depends on sqflite_entities >=0.0.2 which requires the Flutter SDK, version solving failed.
Flutter users should use `flutter pub` instead of `dart pub`.
failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because sqflite_entities_generator depends on sqflite_entities >=0.0.2 which requires the Flutter SDK, version solving failed.

Flutter users should use `flutter pub` instead of `dart pub`.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

0
likes
40
pub points
6%
popularity

Publisher

verified publishertelequiz.online

sqflite entities generator used for sql_entities packages, see more details on https://github.com/guid-empty/sqflite_entities

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

analyzer, build, build_runner, source_gen, sqflite_entities

More

Packages that depend on sqflite_entities_generator