solana_wallets_flutter 1.1.1 copy "solana_wallets_flutter: ^1.1.1" to clipboard
solana_wallets_flutter: ^1.1.1 copied to clipboard

Platformweb

A flutter plugin to connect to a users wallet like phantom, solflare, etc.

4
likes
120/ 140
pub points
39%
popularity

We analyzed this package 3 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 75 API elements (72.0 %) have documentation comments.

Some symbols that are missing documentation: solana_wallets_flutter.WalletAccountError, solana_wallets_flutter.WalletConfigError, solana_wallets_flutter.WalletConnectionError, solana_wallets_flutter.WalletDisconnectedError, solana_wallets_flutter.WalletDisconnectionError.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:solana_wallets_flutter/solana_wallets_flutter.dart that imports:
  • package:solana_wallets_flutter/src/wallet_error.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:solana_wallets_flutter/solana_wallets_flutter.dart that imports:
  • package:solana_wallets_flutter/src/wallet_error.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:solana_wallets_flutter/solana_wallets_flutter.dart that imports:
  • package:solana_wallets_flutter/src/wallet_error.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:solana_wallets_flutter/solana_wallets_flutter.dart that imports:
  • package:solana_wallets_flutter/src/wallet_error.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:solana_wallets_flutter/solana_wallets_flutter.dart that imports:
  • package:solana_wallets_flutter/src/wallet_error.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Use the generic function type syntax in 'typedef's.

lib/solana_wallets_flutter_ui.dart:10:16

   ╷
10 │ typedef String WalletStateToText(BuildContext context, WalletState state);
   │                ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/solana_wallets_flutter_ui.dart

INFO: Use the generic function type syntax in 'typedef's.

lib/solana_wallets_flutter_ui.dart:16:16

   ╷
16 │ typedef Widget WidgetOverrideBuilder(BuildContext context, WidgetBuilder child);
   │                ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/solana_wallets_flutter_ui.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_svg ^2.0.2 2.0.10+1 2.0.10+1
inject_js ^2.0.0 2.0.0 2.0.0
js ^0.6.5 0.6.7 0.7.1
meta ^1.8.0 1.12.0 1.15.0
url_launcher ^6.1.10 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.5` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

4
likes
120
pub points
39%
popularity

Publisher

verified publisherepnw.eu

A flutter plugin to connect to a users wallet like phantom, solflare, etc.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter, flutter_svg, inject_js, js, meta, url_launcher

More

Packages that depend on solana_wallets_flutter