socket_io_client 2.0.3+1 copy "socket_io_client: ^2.0.3+1" to clipboard
socket_io_client: ^2.0.3+1 copied to clipboard

Dartlang port of socket.io-client for web, flutter, dartvm to use

1306
likes
140/ 160
pub points
99%
popularity

We analyzed this package 6 hours ago, and awarded it 140 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/rikulo/socket.io-client-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

35 out of 91 API elements (38.5 %) have documentation comments.

Some symbols that are missing documentation: socket_io_client.DartySocket.onConnect, socket_io_client.DartySocket.onConnectError, socket_io_client.DartySocket.onConnectTimeout, socket_io_client.DartySocket.onConnecting, socket_io_client.DartySocket.onDisconnect.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The referenced identifier is a wildcard.

lib/src/engine/socket.dart:706:49

    ╷
706 │       transports.where((_) => upgrades.contains(_)).toList();
    │                                                 ^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/engine/socket.dart

INFO: The import of 'dart:js' is unnecessary because all of the used elements are also provided by the import of 'package:js/js_util.dart'.

lib/src/engine/transport/jsonp_transport.dart:3:8

  ╷
3 │ import 'dart:js' hide JsArray;
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/engine/transport/jsonp_transport.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
js ^0.6.3 0.6.7 0.7.1
logging ^1.0.1 1.2.0 1.2.0
socket_io_common ^2.0.3 2.0.3 2.0.3
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

1306
likes
140
pub points
99%
popularity

Publisher

unverified uploader

Dartlang port of socket.io-client for web, flutter, dartvm to use

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

js, logging, socket_io_common

More

Packages that depend on socket_io_client