shurjopay 2.0.5 copy "shurjopay: ^2.0.5" to clipboard
shurjopay: ^2.0.5 copied to clipboard

Official shurjoPay flutter package for merchants or service providers to integrate our payment system with their Flutter applications.

11
likes
95/ 140
pub points
71%
popularity

We analyzed this package 2 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:82:27

   ╷
82 │ <p>This code is under the <a href="http://www.opensource.org/licenses/mit-license.php">MIT open source License</a>.</p>
   │                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

18 out of 231 API elements (7.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: api_endpoints, api_endpoints.ApiEndpoints, api_endpoints.ApiEndpoints.ApiEndpoints, api_endpoints.ApiEndpoints.checkout, api_endpoints.ApiEndpoints.getToken.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:shurjopay/shurjopay.dart that imports:
  • package:shurjopay/controllers/payment_controller.dart that imports:
  • package:shurjopay/views/payment_gateway_webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'DioError' is deprecated and shouldn't be used. Use DioException instead. This will be removed in 6.0.0.

lib/services/dio_service.dart:63:17

   ╷
63 │       onError: (DioError error, handler) async {
   │                 ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/services/dio_service.dart

INFO: 'WillPopScope' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/views/empty_loader.dart:12:12

   ╷
12 │     return WillPopScope(
   │            ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/views/empty_loader.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.4.0 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
get_it ^7.6.7 7.7.0 7.7.0
webview_flutter ^4.7.0 4.7.0 4.7.0
webview_flutter_android ^3.15.0 3.16.0 3.16.0
webview_flutter_wkwebview ^3.12.0 3.13.0 3.13.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_platform_interface - 2.10.0 2.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

11
likes
95
pub points
71%
popularity

Publisher

verified publishershurjomukhi.com.bd

Official shurjoPay flutter package for merchants or service providers to integrate our payment system with their Flutter applications.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, get_it, webview_flutter, webview_flutter_android, webview_flutter_wkwebview

More

Packages that depend on shurjopay