seven_face_authentification 1.0.1 icon indicating copy to clipboard operation
seven_face_authentification: ^1.0.1 copied to clipboard

A facial recognition system developed by sevenGps .

3
likes
70/ 130
pub points
0%
popularity

We analyzed this package 2 hours ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 63 API elements (23.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:seven_face_authentification/src/utils/Constant.dart that imports:
  • package:native_progress_hud/native_progress_hud.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:seven_face_authentification/src/utils/Constant.dart that imports:
  • package:native_progress_hud/native_progress_hud.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:seven_face_authentification/src/utils/Constant.dart that imports:
  • package:native_progress_hud/native_progress_hud.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:seven_face_authentification/src/utils/Constant.dart that imports:
  • package:native_progress_hud/native_progress_hud.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:seven_face_authentification/seven_face_authentification.dart that imports:
  • package:seven_face_authentification/src/SevenRecognition.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 35 issues. Showing the first 2:

INFO: The import of 'package:flutter/rendering.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/SevenRecognition.dart:16:8

   ╷
16 │ import 'package:flutter/rendering.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/SevenRecognition.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/SevenRecognition.dart:35:16

   ╷
35 │   final String AfterVerificationOrRegistrationSuccessRouteName;
   │                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/SevenRecognition.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animations^1.1.21.1.22.0.2
async^2.4.12.9.02.9.0
awesome_dialog^1.1.31.3.22.2.1
camera^0.5.8+50.5.8+170.9.5+1
cupertino_icons^0.1.30.1.31.0.4
dio^3.0.103.0.104.0.6
flutterflutter0.0.00.0.0
flutter_spinkit^4.1.2+14.1.2+15.1.0
font_awesome_flutter^8.7.08.12.010.1.0
http^0.12.20.12.20.13.4
image^2.1.122.1.193.1.3
image_cropper^1.2.21.5.12.0.3
image_picker^0.6.6+10.6.7+220.8.5+3
modal_bottom_sheet^0.2.0+10.2.22.0.1
native_progress_hud^1.0.31.0.51.0.5
path^1.7.01.8.11.8.1
path_provider^1.6.141.6.282.0.10
simple_animations^2.2.22.5.14.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.3.0
args-1.6.02.3.1
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.1
crypto-2.1.53.0.2
ffi-1.2.11.2.1
file-6.1.26.1.2
flare_dart-2.3.42.3.4
flare_flutter-2.0.63.0.2
flutter_plugin_android_lifecycle-1.0.112.0.6
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.5.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.6
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.0.6
pedantic-1.11.11.11.1
petitparser-3.1.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
sa_v1_migration-1.1.21.1.2
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
supercharged-1.12.02.1.1
supercharged_dart-1.4.02.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
win32-2.6.12.6.1
xdg_directories-0.1.20.2.0+1
xml-4.5.16.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 14 issues. Showing the first 2:

The constraint `^1.1.2` on animations does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions animations to update the constraint.

The constraint `^1.1.3` on awesome_dialog does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions awesome_dialog to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.