sentry 5.1.0
sentry: ^5.1.0 copied to clipboard

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

Stable versions of sentry

Version Min Dart SDK Uploaded Documentation Archive
5.1.0 Null safety 2.12 Jun 7, 2021 Go to the documentation of sentry 5.1.0 Download sentry 5.1.0 archive
5.0.0 Null safety 2.12 Mar 31, 2021 Go to the documentation of sentry 5.0.0 Download sentry 5.0.0 archive
4.0.6 2.8 Mar 1, 2021 Go to the documentation of sentry 4.0.6 Download sentry 4.0.6 archive
4.0.5 2.8 Feb 19, 2021 Go to the documentation of sentry 4.0.5 Download sentry 4.0.5 archive
4.0.4 2.8 Jan 26, 2021 Go to the documentation of sentry 4.0.4 Download sentry 4.0.4 archive
4.0.3 2.8 Jan 22, 2021 Go to the documentation of sentry 4.0.3 Download sentry 4.0.3 archive
4.0.2 2.8 Jan 19, 2021 Go to the documentation of sentry 4.0.2 Download sentry 4.0.2 archive
4.0.1 2.8 Dec 16, 2020 Go to the documentation of sentry 4.0.1 Download sentry 4.0.1 archive
4.0.0 2.8 Dec 10, 2020 Go to the documentation of sentry 4.0.0 Download sentry 4.0.0 archive
3.0.1 2.0 Jan 24, 2020 Go to the documentation of sentry 3.0.1 Download sentry 3.0.1 archive
3.0.0+1 2.0 Dec 11, 2019 Go to the documentation of sentry 3.0.0+1 Download sentry 3.0.0+1 archive
3.0.0 2.0 Dec 11, 2019 Go to the documentation of sentry 3.0.0 Download sentry 3.0.0 archive
2.3.1 2.0 Oct 16, 2019 Go to the documentation of sentry 2.3.1 Download sentry 2.3.1 archive
2.3.0 2.0 Oct 15, 2019 Go to the documentation of sentry 2.3.0 Download sentry 2.3.0 archive
2.2.0 2.0 Jan 9, 2019 Go to the documentation of sentry 2.2.0 Download sentry 2.2.0 archive
2.1.1 2.0 (dev) Oct 9, 2018 Go to the documentation of sentry 2.1.1 Download sentry 2.1.1 archive
2.1.0 2.0 (dev) Jul 30, 2018 Go to the documentation of sentry 2.1.0 Download sentry 2.1.0 archive
2.0.2 2.0 (dev) May 15, 2018 Go to the documentation of sentry 2.0.2 Download sentry 2.0.2 archive
2.0.1 2.0 (dev) Apr 26, 2018 Go to the documentation of sentry 2.0.1 Download sentry 2.0.1 archive
2.0.0 2.0 (dev) Mar 21, 2018 Go to the documentation of sentry 2.0.0 Download sentry 2.0.0 archive
1.0.0 Mar 21, 2018 Go to the documentation of sentry 1.0.0 Download sentry 1.0.0 archive
0.0.6 Sep 18, 2017 Go to the documentation of sentry 0.0.6 Download sentry 0.0.6 archive
0.0.5 Aug 15, 2017 Go to the documentation of sentry 0.0.5 Download sentry 0.0.5 archive
0.0.4 Aug 7, 2017 Go to the documentation of sentry 0.0.4 Download sentry 0.0.4 archive
0.0.3 Jun 23, 2017 Go to the documentation of sentry 0.0.3 Download sentry 0.0.3 archive
0.0.2 Jun 21, 2017 Go to the documentation of sentry 0.0.2 Download sentry 0.0.2 archive
0.0.1 Jun 21, 2017 Go to the documentation of sentry 0.0.1 Download sentry 0.0.1 archive

Prerelease versions of sentry

Version Min Dart SDK Uploaded Documentation Archive
5.1.0-beta.1 Null safety 2.12 May 11, 2021 Go to the documentation of sentry 5.1.0-beta.1 Download sentry 5.1.0-beta.1 archive
4.1.0-nullsafety.1 Null safety 2.12 Mar 15, 2021 Go to the documentation of sentry 4.1.0-nullsafety.1 Download sentry 4.1.0-nullsafety.1 archive
4.1.0-nullsafety.0 Null safety 2.12 Mar 8, 2021 Go to the documentation of sentry 4.1.0-nullsafety.0 Download sentry 4.1.0-nullsafety.0 archive
4.0.0-beta.2 2.8 Dec 7, 2020 Go to the documentation of sentry 4.0.0-beta.2 Download sentry 4.0.0-beta.2 archive
4.0.0-beta.1 2.8 Dec 3, 2020 Go to the documentation of sentry 4.0.0-beta.1 Download sentry 4.0.0-beta.1 archive
4.0.0-alpha.2 2.8 Nov 20, 2020 Go to the documentation of sentry 4.0.0-alpha.2 Download sentry 4.0.0-alpha.2 archive
4.0.0-alpha.1 2.0 Oct 29, 2020 Go to the documentation of sentry 4.0.0-alpha.1 Download sentry 4.0.0-alpha.1 archive
3.0.0-dev0 2.0 Dec 1, 2019 Go to the documentation of sentry 3.0.0-dev0 Download sentry 3.0.0-dev0 archive
197
likes
130
pub points
98%
popularity

Publisher

sentry.io

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http, meta, stack_trace, uuid

More

Packages that depend on sentry