sentry 4.0.5
sentry: ^4.0.5 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

147
likes
110 / 110
pub points
98 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 336 out of 461 API elements (72.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.13.0
meta^1.0.01.2.41.3.0
stack_trace^1.0.01.9.61.10.0
uuid^2.0.02.2.23.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
http_parser-3.1.44.0.0
path-1.7.01.8.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`, that was published 20 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.0.0` on uuid does not support the stable version `3.0.0`, that was published 3 days ago.

When uuid is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

147
likes
110
pub points
98%
popularity

Publisher

sentry.io

A crash reporting library for Dart that sends crash reports to Sentry.io. This library supports Dart VM and Web. For Flutter consider sentry_flutter instead.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http, meta, stack_trace, uuid

More

Packages that depend on sentry