scrobblenaut 2.0.5
scrobblenaut: ^2.0.5 copied to clipboard

A deadly simple LastFM API Wrapper for Dart. So deadly simple that it's gonna hit the mark.

2
likes
90/ 130
pub points
52%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/scrobblenaut_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 401 out of 539 API elements (74.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:scrobblenaut/scrobblenaut.dart that imports:
  • package:scrobblenaut/src/extensions/user_extension.dart that imports:
  • package:scrobblenaut/lastfm_methods.dart that imports:
  • package:scrobblenaut/src/methods/user_methods.dart that imports:
  • package:scrobblenaut/src/core/request.dart that imports:
  • package:scrobblenaut/src/core/lastfm.dart that imports:
  • package:scrobblenaut/src/tools/spaceship.dart that imports:
  • package:dio/adapter.dart that imports:
  • package:dio/src/adapters/io_adapter.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.1
crypto^2.1.52.1.53.0.1
dio^3.0.93.0.104.0.0
json_annotation^3.0.13.1.14.3.0
meta^1.1.81.7.01.7.0
universal_io^1.0.21.0.22.0.4
xml^4.2.04.5.15.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
petitparser-3.1.04.4.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
zone_local-0.1.20.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

2
likes
90
pub points
52%
popularity

Publisher

nebulino.cloud

A deadly simple LastFM API Wrapper for Dart. So deadly simple that it's gonna hit the mark.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

convert, crypto, dio, json_annotation, meta, universal_io, xml

More

Packages that depend on scrobblenaut