scidart 0.0.2-dev.12 copy "scidart: ^0.0.2-dev.12" to clipboard
scidart: ^0.0.2-dev.12 copied to clipboard

Cross-platform scientific library for Dart. The main goal of SciDart is run where Dart can run, in other words, run on Flutter, Dart CLI, Dart web, etc.

113
likes
130/ 140
pub points
92%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

251 out of 417 API elements (60.2 %) have documentation comments.

Some symbols that are missing documentation: numdart, numdart.Array.Array.empty, numdart.Array.Array.fixed, numdart.Array.Array.fromArray, numdart.Array.l.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 164 issues. Showing the first 2:

INFO: Missing a corresponding override of 'hashCode'.

lib/src/numdart/arrays_base/array.dart:200:17

    ╷
200 │   bool operator ==(b) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/numdart/arrays_base/array.dart

INFO: Missing a corresponding override of 'hashCode'.

lib/src/numdart/arrays_base/array2d.dart:247:17

    ╷
247 │   bool operator ==(b) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/numdart/arrays_base/array2d.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

113
likes
130
pub points
92%
popularity

Publisher

unverified uploader

Cross-platform scientific library for Dart. The main goal of SciDart is run where Dart can run, in other words, run on Flutter, Dart CLI, Dart web, etc.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

More

Packages that depend on scidart