sap_connect 0.1.0
sap_connect: ^0.1.0 copied to clipboard

provides connection to the SAP server, making requests to the SAP server, receiving and processing data from the SAP server in response to requests

3
likes
60/ 130
pub points
38%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +81 ms] executing: uname -m
[  +38 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +7 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +8 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 18116933e77adc82f80866c928266a5b4f1ed645
[        ] executing: [/tool/stable/flutter/] git tag --points-at 18116933e77adc82f80866c928266a5b4f1ed645
[  +15 ms] Exit code 0 from: git tag --points-at 18116933e77adc82f80866c928266a5b4f1ed645
[        ] 2.5.3
[  +11 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +6 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +64 ms] Unable to locate an Android SDK.
[   +5 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +5 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +62 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +12 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/pub upgrade --verbose
MSG : Resolving dependencies...
[+1238 ms] "flutter pub" took 1,338ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[        ] exiting with code 1

stderr: FINE: Pub 2.14.4
SLVR: fact: sap_connect is 0.1.0
SLVR: derived: sap_connect
SLVR: fact: sap_connect depends on async ^2.3.0
SLVR: fact: sap_connect depends on cookie_jar ^1.0.0
SLVR: fact: sap_connect depends on crypto ^2.0.6
SLVR: fact: sap_connect depends on device_id ^0.1.3
SLVR: fact: sap_connect depends on flutter any from sdk
SLVR: fact: sap_connect depends on flutter_localizations any from sdk
SLVR: fact: sap_connect depends on fluttertoast ^2.1.2
SLVR: fact: sap_connect depends on intl ^0.15.7
SLVR: fact: sap_connect depends on open_file ^1.2.3+1
SLVR: fact: sap_connect depends on package_info ^0.4.0+1
SLVR: fact: sap_connect depends on path_provider ^0.5.0+1
SLVR: fact: sap_connect depends on shared_preferences ^0.4.2
SLVR:   selecting sap_connect
SLVR:   derived: shared_preferences ^0.4.2
SLVR:   derived: path_provider ^0.5.0+1
SLVR:   derived: package_info ^0.4.0+1
SLVR:   derived: open_file ^1.2.3+1
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:92:3)
           <asynchronous suspension>



Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/sap_application.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/sap_authorization.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because sap_connect depends on flutter_localizations any from sdk which depends on intl 0.17.0, intl 0.17.0 is required.
So, because sap_connect depends on intl ^0.15.7, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

3
likes
60
pub points
38%
popularity

provides connection to the SAP server, making requests to the SAP server, receiving and processing data from the SAP server in response to requests

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

async, cookie_jar, crypto, device_id, flutter, flutter_localizations, fluttertoast, intl, open_file, package_info, path_provider, shared_preferences

More

Packages that depend on sap_connect