device_id 0.2.0

  • Example
  • Installing
  • Versions
  • 92

device_id #

A Flutter plugin for retrieving the uid of a device

Getting Started #

To retrieve the id just import and call String device_id = await DeviceId.getID;. To retrieve the imei call String imei = await DeviceId.getIMEI;. To retrieve the meid call String meid = await DeviceId.getMEID;. For imei and meid platform version >=26 is required, otherwise it will produces a PlatformExcpetion Now you are good to go! Note: device ids are not safe as you think, rooted/jailbreaked devices are able to change the ids.

0.2.0 #

Add androidx support, add IMEI, add MEID

0.1.3 #

Upgrade to swift 4.1.x

0.1.2 #

iOS error fix

0.1.1 #

Bug fix

0.1.0 #

Added functions


device_id_example #

Demonstrates how to use the device_id plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  device_id: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:device_id/device_id.dart';
Version Uploaded Documentation Archive
0.2.0 Apr 11, 2019 Go to the documentation of device_id 0.2.0 Download device_id 0.2.0 archive
0.1.3 Sep 17, 2018 Go to the documentation of device_id 0.1.3 Download device_id 0.1.3 archive
0.1.2 Aug 17, 2018 Go to the documentation of device_id 0.1.2 Download device_id 0.1.2 archive
0.1.1 Jul 7, 2018 Go to the documentation of device_id 0.1.1 Download device_id 0.1.1 archive
0.1.0 Jul 7, 2018 Go to the documentation of device_id 0.1.0 Download device_id 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8