s3i_flutter 0.5.0 copy "s3i_flutter: ^0.5.0" to clipboard
s3i_flutter: ^0.5.0 copied to clipboard

discontinued

A library that makes it easy to communicate with the S³I (Smart Systems Service Infrastructure of the KWH4.0).

1
likes
80/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

366 out of 367 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: s3i_flutter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

ERROR: The name 'FallThroughError' isn't a type and can't be used in an on-catch clause.

lib/src/directory/thing.dart:69:14

   ╷
69 │         } on FallThroughError {
   │              ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/directory/thing.dart

ERROR: The method 'FallThroughError' isn't defined for the type 'Thing'.

lib/src/directory/thing.dart:192:15

    ╷
192 │         throw FallThroughError();
    │               ^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/directory/thing.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.1 3.0.3 3.0.3
dart_amqp ^0.2.0 0.2.5 0.2.5
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
uuid ^3.0.4 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.4` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
80
pub points
0%
popularity

Publisher

verified publisherlukas-poque.dev

A library that makes it easy to communicate with the S³I (Smart Systems Service Infrastructure of the KWH4.0).

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, dart_amqp, flutter, http, uuid

More

Packages that depend on s3i_flutter