retrofit_flutter 1.0.5 icon indicating copy to clipboard operation
retrofit_flutter: ^1.0.5 copied to clipboard

retrofit for flutter

1
likes
100/ 140
pub points
66%
popularity

We analyzed this package 44 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 34 out of 100 API elements (34.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 29 issues. Showing the first 2:

WARNING: The left operand can't be null, so the right operand is never executed.

lib/src/generator.dart:421:9

    ╷
421 │         (httpMethod.peek('autoCastResponse')?.boolValue ?? true));
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/generator.dart

WARNING: Missing case clause for 'null'.

lib/src/generator.dart:487:11

    ╷
487 │           switch (clientAnnotation.parser) {
    │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^2.0.02.8.05.4.0
build^2.0.02.3.12.3.1
built_collection^5.0.05.1.15.1.1
code_builder^4.0.04.4.04.4.0
collection^1.15.01.17.11.17.1
dart_style^2.0.02.2.12.2.4
dio^4.0.04.0.64.0.6
meta^1.3.01.9.01.9.0
source_gen^1.0.01.2.21.2.7
tuple^2.0.02.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.052.0.0
args-2.3.22.3.2
async-2.10.02.10.0
built_value-8.4.38.4.3
cli_util-0.3.50.3.5
convert-3.1.13.1.1
crypto-3.0.23.0.2
file-6.1.46.1.4
fixnum-1.1.01.1.0
glob-2.1.12.1.1
http_parser-4.0.24.0.2
logging-1.1.11.1.1
matcher-0.12.140.12.14
package_config-2.1.02.1.0
path-1.8.31.8.3
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on analyzer does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.