req_fun 2.0.1 copy "req_fun: ^2.0.1" to clipboard
req_fun: ^2.0.1 copied to clipboard

A package for almost every flutter project. Includes extension functions, prefs, validator, searchable text...

4
likes
140/ 160
pub points
57%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

32 out of 136 API elements (23.5 %) have documentation comments.

Some symbols that are missing documentation: req_fun, req_fun.DateFormats.DD_MMMM_YY, req_fun.DateFormats.DD_MMMM_YYYY, req_fun.DateFormats.DD_MMM_YY, req_fun.DateFormats.DD_MMM_YYYY.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:req_fun/req_fun.dart that imports:
  • package:req_fun/src/functions/try_catch.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: Statements in an if should be enclosed in a block.

lib/src/form_validator/validator.dart:10:9

   ╷
10 │         return errorMsg;
   │         ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/form_validator/validator.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/form_validator/validator.dart:12:9

   ╷
12 │         return null;
   │         ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/form_validator/validator.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
date_format ^2.0.7 2.0.7 2.0.7
flutter flutter 0.0.0 0.0.0
intl ^0.19.0 0.19.0 0.19.0
shared_preferences ^2.2.3 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
140
pub points
57%
popularity

Publisher

unverified uploader

A package for almost every flutter project. Includes extension functions, prefs, validator, searchable text...

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

date_format, flutter, intl, shared_preferences

More

Packages that depend on req_fun