refined_markdown 1.2.2
refined_markdown: ^1.2.2 copied to clipboard

A simple Markdown renderer that is written mostly in dart (grammar analysing and rendering part). Simple, quiet, fast, that is all refined markdown is intended to be.

6
likes
80/ 130
pub points
19%
popularity

We analyzed this package on Sep 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 167 API elements (1.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:refined_markdown/refined_markdown.dart that imports:
  • package:refined_markdown/src/support.dart that imports:
  • package:refined_markdown/src/renderer.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.0.02.5.13.1.0
flutterflutter0.0.00.0.0
flutter_highlight^0.6.00.6.00.7.0
highlight^0.6.00.6.00.7.0
url_launcher^5.4.25.7.106.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
image-3.0.53.0.5
js-0.6.30.6.3
meta-1.7.01.7.0
octo_image-0.3.01.0.0+1
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.3.04.3.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.1
process-4.2.34.2.3
rxdart-0.25.00.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
uuid-3.0.43.0.4
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0
xml-5.3.05.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.0.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.6.0` on flutter_highlight does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_highlight to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

6
likes
80
pub points
19%
popularity

Publisher

autokaka.dogshitpiestudio.cn

A simple Markdown renderer that is written mostly in dart (grammar analysing and rendering part). Simple, quiet, fast, that is all refined markdown is intended to be.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

cached_network_image, flutter, flutter_highlight, highlight, url_launcher

More

Packages that depend on refined_markdown