quds_provider 0.0.6+3 copy "quds_provider: ^0.0.6+3" to clipboard
quds_provider: ^0.0.6+3 copied to clipboard

A simple state manager, states now are simple to reach, easy to save and restore.

9
likes
130/ 140
pub points
24%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://www.alrazysoft.com was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

69 out of 70 API elements (98.6 %) have documentation comments.

Some symbols that are missing documentation: src.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: Statements in a for should be enclosed in a block.

lib/_src/quds_app.dart:42:9

   ╷
42 │ ┌         if (p.runtimeType == op.runtimeType) {
43 │ │           op = o;
44 │ │           break;
45 │ └         }
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/_src/quds_app.dart

INFO: Statements in an if should be enclosed in a block.

lib/_src/quds_app_controller.dart:75:7

   ╷
75 │       return item.value;
   │       ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/_src/quds_app_controller.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
encrypt ^5.0.0 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
shared_preferences ^2.0.5 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.1 3.9.1
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

9
likes
130
pub points
24%
popularity

Publisher

verified publisherquds.cc

A simple state manager, states now are simple to reach, easy to save and restore.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

encrypt, flutter, shared_preferences

More

Packages that depend on quds_provider