qr_plus 1.2.0 copy "qr_plus: ^1.2.0" to clipboard
qr_plus: ^1.2.0 copied to clipboard

Advanced all-in-one qr code package with support for safe qr codes.

6
likes
110/ 140
pub points
46%
popularity

We analyzed this package 17 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

330 out of 386 API elements (85.5 %) have documentation comments.

Some symbols that are missing documentation: qr_plus, qr_plus.AddressType.AddressType.fromRawValue, qr_plus.BarcodeFormat.BarcodeFormat.fromRawValue, qr_plus.BarcodeType.BarcodeType.fromRawValue, qr_plus.CameraFacing.CameraFacing.fromRawValue.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/utility/utility.dart that imports:
  • package:qr_plus/src/utility/src/connectivity_result_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/feature/renderer/view/view.dart that imports:
  • package:qr_plus/src/feature/renderer/cubit/cubit.dart that imports:
  • package:screen_capture_event/screen_capture_event.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/utility/utility.dart that imports:
  • package:qr_plus/src/utility/src/connectivity_result_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/feature/renderer/view/view.dart that imports:
  • package:qr_plus/src/feature/renderer/cubit/cubit.dart that imports:
  • package:screen_capture_event/screen_capture_event.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/utility/utility.dart that imports:
  • package:qr_plus/src/utility/src/connectivity_result_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:qr_plus/qr_plus.dart that imports:
  • package:qr_plus/src/utility/utility.dart that imports:
  • package:qr_plus/src/utility/src/connectivity_result_extension.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/feature/reader/cubit/cubit.gen.dart:118:17

    ╷
118 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/feature/reader/cubit/cubit.gen.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/feature/renderer/cubit/cubit.gen.dart:265:17

    ╷
265 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/feature/renderer/cubit/cubit.gen.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus ^4.0.0 4.0.2 6.0.2
encrypt ^5.0.1 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.2 8.1.5 8.1.5
freezed ^2.3.4 2.5.2 2.5.2
freezed_annotation ^2.2.0 2.4.1 2.4.1
json_annotation ^4.8.1 4.8.1 4.8.1
mobile_scanner ^3.2.0 3.5.7 4.0.1
ntp ^2.0.0 2.0.0 2.0.0
qr_flutter ^4.1.0 4.1.0 4.1.0
screen_capture_event ^1.1.1 1.1.1 1.1.1
uuid ^3.0.7 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.5.0 2.5.0
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
bloc - 8.1.4 8.1.4
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
connectivity_plus_platform_interface - 1.2.4 2.0.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
glob - 2.1.2 2.1.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
nm - 0.5.0 0.5.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.8.0 3.8.0
provider - 6.1.2 6.1.2
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
qr - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
xml - 6.5.0 6.5.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^4.0.0` on connectivity_plus does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

The constraint `^3.2.0` on mobile_scanner does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions mobile_scanner to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.