pubspec_yaml 2.0.1

Dart native js
Flutter Android iOS web

Dart library to access and manipulate content of pubpec.yaml files

8
likes
100 / 110
pub points
78 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 37 out of 145 API elements (25.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: The declaration 'load' isn't referenced.

lib/src/package_dependency_spec/package_dependency_spec.g.dart:19:32

   ╷
19 │   static PackageDependencySpec load<$T extends PackageDependencySpecRecordBase<$T>>(
   │                                ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/package_dependency_spec/package_dependency_spec.g.dart

INFO: The value of the field 'hosted' isn't used.

lib/src/package_dependency_spec/serializers.dart:64:16

   ╷
64 │   static const hosted = 'hosted';
   │                ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/package_dependency_spec/serializers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.01.14.131.14.13
functional_data^0.3.00.3.00.3.0
json2yaml^1.0.01.0.11.0.1
meta^1.1.01.2.31.2.3
plain_optional^0.1.00.1.30.1.3
sum_types^0.2.00.2.1+20.2.1+2
yaml^2.2.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

8
likes
100
pub points
78%
popularity

Dart library to access and manipulate content of pubpec.yaml files

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alexei.sintotski@gmail.com

License

MIT (LICENSE)

Dependencies

collection, functional_data, json2yaml, meta, plain_optional, sum_types, yaml

More

Packages that depend on pubspec_yaml