pubspec 0.1.5 icon indicating copy to clipboard operation
pubspec: ^0.1.5 copied to clipboard

A library for manipulating [pubspec](https://www.dartlang.org/tools/pub/pubspec.html) files

10
likes
80/ 120
pub points
86%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 10icon to trigger folding of the section

10/10 points: Package has an example

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Override `hashCode` if overriding `==`.

lib/src/dependency.dart:125:17

    ╷
125 │   bool operator ==(other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dependency.dart

INFO: Override `hashCode` if overriding `==`.

lib/src/dependency.dart:144:17

    ╷
144 │   bool operator ==(other) => other is SdkReference && other.sdk == sdk;
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dependency.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.6.21.8.21.8.2
pub_semver^1.4.21.4.42.1.1
uri^0.11.3+10.11.41.0.0
yaml^2.1.152.2.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.16.01.16.0
matcher-0.12.110.12.11
meta-1.8.01.8.0
quiver-2.1.53.1.0
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.4.2` on pub_semver does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions pub_semver to update the constraint.

The constraint `^0.11.3+1` on uri does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions uri to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.0.

10
likes
80
pub points
86%
popularity

Publisher

verified publisher icontheconduit.dev

A library for manipulating [pubspec](https://www.dartlang.org/tools/pub/pubspec.html) files

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

path, pub_semver, uri, yaml

More

Packages that depend on pubspec