pub_update_checker 1.2.0 copy "pub_update_checker: ^1.2.0" to clipboard
pub_update_checker: ^1.2.0 copied to clipboard

Check if your dart script package is up to date in one line.

2
likes
140/ 140
pub points
32%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 3 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:pub_update_checker/pub_update_checker.dart that imports:
  • package:pub_update_checker/src/pub_update_checker_base.dart that imports:
  • package:pub_api_client/pub_api_client.dart that imports:
  • package:pub_api_client/src/pub_api_client_base.dart that imports:
  • package:pub_api_client/src/models/pub_package_model.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
pub_api_client ^2.2.1 2.7.0 2.7.0
pub_semver ^2.1.0 2.1.4 2.1.4
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
dart_mappable - 4.2.2 4.2.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
matcher - 0.12.16+1 0.12.16+1
meta - 1.14.0 1.14.0
oauth2 - 2.0.2 2.0.2
path - 1.9.0 1.9.0
pubspec - 2.3.0 2.3.0
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
type_plus - 2.1.1 2.1.1
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

2
likes
140
pub points
32%
popularity

Publisher

verified publisherrexios.dev

Check if your dart script package is up to date in one line.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

pub_api_client, pub_semver, yaml

More

Packages that depend on pub_update_checker