pub_api_client 2.0.5
pub_api_client: ^2.0.5 copied to clipboard

An API Client for Pub to interact with public package information.

19
likes
120 / 130
pub points
64 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 34 out of 151 API elements (22.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pub_api_client/pub_api_client.dart that imports:
  • package:pub_api_client/src/pub_api_client_base.dart that imports:
  • package:pub_api_client/src/models/pub_package_model.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
freezed_annotation^0.14.10.14.30.14.3
http^0.13.10.13.30.13.3
json_annotation^4.0.14.1.04.1.0
oauth2^2.0.02.0.02.0.0
path^1.8.01.8.01.8.0
pubspec^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
http_parser-4.0.04.0.0
matcher-0.12.100.12.10
meta-1.7.01.7.0
pub_semver-2.0.02.0.0
quiver-3.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

19
likes
120
pub points
64%
popularity

Publisher

fvm.app

An API Client for Pub to interact with public package information.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

freezed_annotation, http, json_annotation, oauth2, path, pubspec

More

Packages that depend on pub_api_client