printing 5.12.0 copy "printing: ^5.12.0" to clipboard
printing: ^5.12.0 copied to clipboard

Plugin that allows Flutter apps to generate and print documents to compatible printers on Android, iOS, macOS, Windows, and Linux, as well as web print.

1488
likes
150/ 160
pub points
100%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/DavBfr/dart_pdf/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

199 out of 246 API elements (80.9 %) have documentation comments.

Some symbols that are missing documentation: printing, printing.PdfActionBarTheme, printing.PdfActionBarTheme.actionSpacing, printing.PdfActionBarTheme.alignment, printing.PdfActionBarTheme.backgroundColor.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:printing/printing.dart that imports:
  • package:printing/src/printing.dart that imports:
  • package:printing/src/interface.dart that imports:
  • package:printing/src/method_channel.dart that imports:
  • package:printing/src/print_job.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'MaterialState' is deprecated and shouldn't be used. Use WidgetState instead. Moved to the Widgets layer to make code available outside of Material. This feature was deprecated after v3.19.0-0.3.pre.

lib/src/preview/page.dart:88:24

   ╷
88 │             ?.resolve({MaterialState.hovered}) ??
   │                        ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/preview/page.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi >=1.1.0 <3.0.0 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
http >=0.13.0 <2.0.0 1.2.1 1.2.1
image ^4.0.02 4.2.0 4.2.0
js >=0.6.3 <1.0.0 0.7.1 0.7.1
meta >=1.3.0 <2.0.0 1.12.0 1.15.0
pdf ^3.10.0 3.10.8 3.10.8
pdf_widget_wrapper >=1.0.0 <2.0.0 1.0.4 1.0.4
plugin_platform_interface ^2.1.0 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
async - 2.11.0 2.11.0
barcode - 2.2.8 2.2.8
bidi - 2.0.10 2.0.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.12.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
qr - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1488
likes
150
pub points
100%
popularity
screenshot

Publisher

verified publishernfet.net

Plugin that allows Flutter apps to generate and print documents to compatible printers on Android, iOS, macOS, Windows, and Linux, as well as web print.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#pdf #printer #print #printing #report

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

ffi, flutter, flutter_web_plugins, http, image, js, meta, pdf, pdf_widget_wrapper, plugin_platform_interface

More

Packages that depend on printing