pip_services3_mongodb 1.1.0
pip_services3_mongodb: ^1.1.0 copied to clipboard

This framework is part of the [Pip.Services](https://github.com/pip-services/pip-services) project. It contains the following MongoDB components.

1
likes
115/ 130
pub points
22%
popularity

We analyzed this package on Oct 18, 2021, and awarded it 115 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:33

  ╷
2 │ <p>This module is a part of the <a href="http://pipservices.org">Pip.Services</a> polyglot microservices toolkit. It provides a set of components to implement MongoDB persistence.</p>
  │                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 76 out of 97 API elements (78.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pip_services3_mongodb/pip_services3_mongodb.dart that imports:
  • package:pip_services3_mongodb/src/persistence/persistence.dart that imports:
  • package:pip_services3_mongodb/src/persistence/IdentifiableMongoDbPersistence.dart that imports:
  • package:pip_services3_mongodb/src/persistence/MongoDbPersistence.dart that imports:
  • package:pip_services3_mongodb/src/persistence/MongoDbConnection.dart that imports:
  • package:pip_services3_mongodb/src/connect/MongoDbConnectionResolver.dart that imports:
  • package:pip_services3_components/pip_services3_components.dart that imports:
  • package:pip_services3_components/src/Component.dart that imports:
  • package:pip_services3_components/src/count/CompositeCounters.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
mongo_dart^0.7.20.7.20.7.2
mongo_dart_query^1.0.21.0.21.0.2
pip_services3_commons^1.1.21.1.41.1.4
pip_services3_components^1.1.11.1.21.1.2
pip_services3_data^1.1.11.1.11.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
analyzer-2.6.02.6.0
async-2.8.22.8.2
basic_utils-3.7.03.7.0
bson-1.0.31.0.3
buffer-1.1.11.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
fixnum-1.0.01.0.0
glob-2.0.22.0.2
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pip_services3_expressions-1.0.11.0.1
pointycastle-3.3.43.3.4
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
rational-1.2.11.2.1
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
sprintf-6.0.06.0.0
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.20.4.2
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

1
likes
115
pub points
22%
popularity

Publisher

entinco.com

This framework is part of the [Pip.Services](https://github.com/pip-services/pip-services) project. It contains the following MongoDB components.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

mongo_dart, mongo_dart_query, pip_services3_commons, pip_services3_components, pip_services3_data

More

Packages that depend on pip_services3_mongodb