pia_framework_base 1.15.2

Flutter Android iOS web

PIA_FrameWork Flutter Base package.

0
likes
60 / 110
pub points
19 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 34 out of 497 API elements (6.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 291 issues. Showing the first 2:

INFO: Name types using UpperCamelCase.

lib/API/PIA_API_Background.dart:9:7

  ╷
9 │ class PIA_API_Background {
  │       ^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/API/PIA_API_Background.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/API/PIA_API_Background.dart:13:10

   ╷
13 │   static Post(String url,Map<String,String> post,PIA_API_CallBack callback) async {
   │          ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/API/PIA_API_Background.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carousel_pro^1.0.01.0.01.0.0
connectivity^0.4.8+10.4.9+50.4.9+5
cupertino_icons^0.1.20.1.31.0.0
dio^3.0.93.0.103.0.10
flutterflutter0.0.00.0.0
flutter_document_picker^4.0.04.0.04.0.0
flutter_html^0.11.10.11.11.0.2
http^0.12.0+40.12.20.12.2
image_crop^0.3.00.3.40.3.4
image_cropper^1.2.11.3.11.3.1
image_picker^0.6.3+40.6.7+120.6.7+12
overlay_support^1.0.21.0.51.0.5
photo_view^0.4.00.4.20.10.2
share^0.6.3+60.6.5+30.6.5+3
shared_preferences^0.5.60.5.12+20.5.12+2
url_launcher^5.4.25.7.55.7.5
Transitive dependencies
PackageConstraintCompatibleLatest
after_layout-1.0.7+21.0.7+2
async-2.4.22.5.0-nullsafety.1
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
connectivity_for_web-0.3.1+20.3.1+2
connectivity_macos-0.1.0+50.1.0+5
connectivity_platform_interface-1.0.61.0.6
csslib-0.16.20.16.2
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_plugin_android_lifecycle-1.0.111.0.11
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.14.0+4
http_parser-3.1.43.1.4
image_picker_platform_interface-1.1.11.1.1
intl-0.16.10.16.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
mime-0.9.70.9.7
path-1.7.01.8.0-nullsafety.1
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
url_launcher_linux-0.0.1+10.0.1+1
url_launcher_macos-0.0.1+80.0.1+8
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.4+10.1.4+1
url_launcher_windows-0.0.1+10.0.1+1
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:15:20

   ╷
15 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^0.11.1` on flutter_html does not support the latest published version `1.0.2`

pubspec.yaml:23:17

   ╷
23 │   flutter_html: ^0.11.1
   │                 ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs