pia_framework_base 0.0.3

  • Readme
  • Changelog
  • Installing
  • 4

pia_framework_base #

A new Flutter package.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pia_framework_base: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pia_framework_base/pia_framework_base.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
4
Learn more about scoring.

We analyzed this package on Nov 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/Form/PIA_RangeSlider.dart: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

Health issues and suggestions

Fix lib/Form/PIA_RangeSlider.dart. (-44.59 points)

Analysis of lib/Form/PIA_RangeSlider.dart failed with 2 errors, 3 hints:

line 87 col 22: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

line 87 col 26: The name 'RangeSlider' is defined in the libraries 'package:flutter/src/material/range_slider.dart' and 'package:flutter_range_slider/src/flutter_range_slider.dart'.

line 4 col 7: Name types using UpperCamelCase.

line 19 col 8: Name non-constant identifiers using lowerCamelCase.

line 37 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/Form/PIA_Form.dart. (-15.67 points)

Analysis of lib/Form/PIA_Form.dart reported 34 hints, including:

line 10 col 7: Name types using UpperCamelCase.

line 19 col 35: Name non-constant identifiers using lowerCamelCase.

line 21 col 10: Name non-constant identifiers using lowerCamelCase.

line 22 col 10: Name non-constant identifiers using lowerCamelCase.

line 24 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/PIA_ChatRoom/PIA_Chatroom.dart. (-13.09 points)

Analysis of lib/PIA_ChatRoom/PIA_Chatroom.dart reported 28 hints, including:

line 2 col 8: Don't import implementation files from another package.

line 17 col 7: Name types using UpperCamelCase.

line 18 col 6: This function has a return type of 'Widget', but doesn't end with a return statement.

line 18 col 13: Name non-constant identifiers using lowerCamelCase.

line 36 col 7: Name types using UpperCamelCase.

Fix additional 28 files with analysis or formatting issues. (-87.55 points)

Additional issues in the following files:

  • lib/API/PIA_API_Tablelist.dart (25 hints)
  • lib/API/PIA_API_Gridlist.dart (21 hints)
  • lib/Popup/PIA_Alert.dart (17 hints)
  • lib/API/PIA_API_Icon_Count.dart (13 hints)
  • lib/API/PIA_API_Page.dart (13 hints)
  • lib/Lang/PIA_Lang.dart (11 hints)
  • lib/API/PIA_API_Popup.dart (7 hints)
  • lib/API/PIA_API_Widget.dart (7 hints)
  • lib/Form/PIA_DropDownMenu.dart (7 hints)
  • lib/Image/PIA_ImagePicker.dart (7 hints)
  • lib/API/PIA_API_Background.dart (6 hints)
  • lib/PIA_ChatRoom/PIA_ImageFilePicker.dart (6 hints)
  • lib/Func/PIA_Timer.dart (5 hints)
  • lib/Image/PIA_Image.dart (5 hints)
  • lib/Image/PIA_Icon.dart (4 hints)
  • lib/Variable/PIA_Global.dart (4 hints)
  • lib/Popup/PIA_Loading.dart (3 hints)
  • lib/View/PIA_Page.dart (3 hints)
  • lib/View/PIA_Strip.dart (3 hints)
  • lib/Func/PIA_Func.dart (2 hints)
  • lib/Image/PIA_ImageSwapView.dart (2 hints)
  • lib/Image/PIA_PhotoView.dart (2 hints)
  • lib/Variable/PIA_Temp.dart (2 hints)
  • lib/View/PIA_Icon_Count.dart (2 hints)
  • lib/View/PIA_WebPage.dart (2 hints)
  • lib/Variable/PIA_LocalValue.dart (1 hint)
  • lib/FCM/PIA_Firebase.dart (Run flutter format to format lib/FCM/PIA_Firebase.dart.)
  • lib/FCM/PIA_Jpush.dart (Run flutter format to format lib/FCM/PIA_Jpush.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/Form/PIA_RangeSlider.dart: The constructor returns type 'dynamic' that isn't of expected type 'Widget'.

Support latest dependencies. (-90 points)

The version constraint in pubspec.yaml does not support the latest published versions for 9 dependencies (cached_network_image, carousel_pro, dio, flutter_html, image_picker, overlay_support, photo_view, shared_preferences, stripe_payment).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and pia_framework_base.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cached_network_image ^0.7.0 0.7.0 1.1.3
carousel_pro ^0.0.13 0.0.13 1.0.0
connectivity ^0.4.3+1 0.4.5+3
cupertino_icons ^0.1.2 0.1.2
dio ^2.1.2 2.2.2 3.0.4
flutter 0.0.0
flutter_document_picker ^3.0.0 3.0.0
flutter_html ^0.10.4 0.10.4 0.11.0
flutter_range_slider ^1.3.0 1.4.0
flutter_webview_plugin ^0.3.4 0.3.8
http ^0.12.0+2 0.12.0+2
image_cropper ^1.0.0 1.1.0
image_picker ^0.5.2 0.5.4+3 0.6.1+11
overlay_support ^0.1.0 0.1.0 1.0.2
photo_view ^0.3.1 0.3.3 0.8.0
share ^0.6.2 0.6.3+1
shared_preferences ^0.4.2 0.4.3 0.5.4+5
stripe_payment ^0.1.0 0.1.1 1.0.5
url_launcher ^5.1.3 5.2.5
Transitive dependencies
after_layout 1.0.7+2
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
cookie_jar 1.0.1
crypto 2.1.3
csslib 0.16.1
flutter_cache_manager 0.3.2 1.1.3
html 0.14.0+3
http_parser 3.1.3
meta 1.1.7 1.1.8
path 1.6.4
path_provider 0.5.0+1 1.4.2
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
sqflite 1.1.7+2
string_scanner 1.0.5
synchronized 2.1.0+1
term_glyph 1.1.0
typed_data 1.1.6
url_launcher_platform_interface 1.0.1
uuid 2.0.2
vector_math 2.0.8
Dev dependencies
flutter_test