peerdart 0.5.4 copy "peerdart: ^0.5.4" to clipboard
peerdart: ^0.5.4 copied to clipboard

Simple peer-to-peer with WebRTC for Dart. PeerJS port for Flutter.

55
likes
130/ 140
pub points
85%
popularity

We analyzed this package 12 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

36 out of 149 API elements (24.2 %) have documentation comments.

Some symbols that are missing documentation: peerdart.AnswerOption, peerdart.AnswerOption.AnswerOption, peerdart.AnswerOption.sdpTransform, peerdart.CallOption, peerdart.CallOption.CallOption.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:peerdart/peerdart.dart that imports:
  • package:peerdart/src/mediaconnection.dart that imports:
  • package:peerdart/src/negotiator.dart that imports:
  • package:peerdart/src/option_interfaces.dart that imports:
  • package:flutter_webrtc/flutter_webrtc.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
events_emitter ^0.5.2 0.5.2 0.5.2
flutter_webrtc ^0.9.35 0.9.48+hotfix.1 0.10.3
http ^1.1.0 1.2.1 1.2.1
uuid ^3.0.6 3.0.7 4.4.0
web_socket_channel ^2.4.0 2.4.5 2.4.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
dart_webrtc - 1.4.1 1.4.1
ffi - 2.1.2 2.1.2
flutter - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
platform_detect - 2.0.11 2.0.11
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
webrtc_interface - 1.2.0 1.2.0
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.35` on flutter_webrtc does not support the stable version `0.10.0`, that was published 5 days ago.

When flutter_webrtc is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_webrtc to update the constraint.

The constraint `^3.0.6` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

55
likes
130
pub points
85%
popularity

Publisher

unverified uploader

Simple peer-to-peer with WebRTC for Dart. PeerJS port for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

events_emitter, flutter_webrtc, http, uuid, web_socket_channel

More

Packages that depend on peerdart