paperplane 0.6.5
paperplane: ^0.6.5 copied to clipboard

A Flying Telegram Bot API Wrapper created from Scratch and Paper.

5
likes
85/ 130
pub points
0%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 85 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:63:49

   ╷
63 │ <p>Please file feature requests and bugs at the <a href="http://github.com/Nebulino/PaperPlane/issues">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/paperplane_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1585 out of 2058 API elements (77.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:paperplane/paperplane.dart that imports:
  • package:paperplane/src/paperplane/telegram.dart that imports:
  • package:paperplane/src/tools/client/telegram_client.dart that imports:
  • package:paperplane/src/tools/client/telegram_response.dart that imports:
  • package:paperplane/telegram.dart that imports:
  • package:paperplane/src/telegram/sticker.dart that imports:
  • package:paperplane/helpers.dart that imports:
  • package:paperplane/src/paperplane/helpers/luggage.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.93.0.104.0.0
json_annotation^3.0.13.1.14.3.0
logger^0.9.10.9.41.1.0
meta^1.1.81.7.01.7.0
path^1.7.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^3.0.1` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

5
likes
85
pub points
0%
popularity

Publisher

nebulino.cloud

A Flying Telegram Bot API Wrapper created from Scratch and Paper.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

dio, json_annotation, logger, meta, path

More

Packages that depend on paperplane