ocean_press 1.0.17
ocean_press: ^1.0.17 copied to clipboard

Smooth Web App Framework for easy and fast construction of Web Applications.

1
likes
80 / 110
pub points
11 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 64 out of 305 API elements (21.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui_kit.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/component/svg.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bones_ui^1.2.01.2.02.0.1
bones_ui_bootstrap^1.2.01.2.02.0.1
dynamic_call^1.0.161.0.182.0.1
enum_to_string^1.0.141.0.142.0.1
intl_messages^1.1.131.1.132.0.1
markdown^3.0.03.0.04.0.0
mercury_client^1.1.161.1.192.0.2
social_login_web^1.0.21.0.22.0.0
swiss_knife^2.5.242.5.263.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
amdjs-1.0.72.0.1
archive-2.0.133.1.2
args-1.6.02.0.0
charcode-1.2.01.2.0
chart_engine-1.1.112.0.1
collection-1.15.01.15.0
color_palette_generator-1.0.42.0.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dom_builder-1.0.262.0.2
dom_tools-1.3.202.0.1
expressions-0.1.50.2.2
html-0.14.0+40.15.0
html_unescape-1.0.22.0.0
intl-0.16.10.17.0
js-0.6.30.6.3
json_object_mapper-1.1.32.0.1
json_render-1.3.82.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
petitparser-3.1.04.1.0
quiver-2.1.53.0.1
resource_portable-2.1.83.0.0
service_worker-0.2.40.2.4
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^1.2.0` on bones_ui does not support the stable version `2.0.1`, that was published 21 days ago.

When bones_ui is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions bones_ui to update the constraint.

The constraint `^1.2.0` on bones_ui_bootstrap does not support the stable version `2.0.1`, that was published 21 days ago.

When bones_ui_bootstrap is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions bones_ui_bootstrap to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.