ocean_press 1.0.10

  • Readme
  • Changelog
  • Installing
  • 71

Ocean_Press #

pub package CI GitHub Tag New Commits Last Commits Pull Requests Code size License

Smooth Web App Framework for easy and fast construction of Web Applications.

Usage #

A simple usage example:

import 'package:ocean_press/ocean_press.dart';

void main() {

 // TODO

}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Colossus.Services #

This is an open-source project from Colossus.Services: the gateway for smooth solutions.

Author #

Graciliano M. Passos: gmpassos@GitHub.

License #

Artistic License - Version 2.0

1.0.10 #

  • AccessTokeState: for login resume.
  • swiss_knife: ^2.5.3
  • mercury_client: ^1.1.8
  • dynamic_call: ^1.0.10
  • dartfmt

1.0.9 #

  • bones_ui: ^1.0.12
  • bones_ui_bootstrap: ^1.0.3
  • enum_to_string: ^1.0.9
  • markdown: ^2.1.4

1.0.8 #

  • Add API Documentation.
  • dartfmt.
  • bones_ui: ^1.0.11
  • bones_ui_bootstrap: ^1.0.1
  • swiss_knife: ^2.5.2
  • mercury_client: ^1.1.7
  • dynamic_call: ^1.0.9
  • intl_messages: ^1.1.8
  • pedantic: ^1.9.0

1.0.7 #

  • OceanExpressApp.initialize( uiOutput , appBuilder )
  • OPRoot.appBuilder
  • OceanExpressApp.readyEvents
  • OceanExpressApp.messages
  • OceanExpressApp.loginFooter/loginBottomContent
  • buildCopyrightFooterMessage()
  • OPExplorerSection
  • Full translation of i18n: en,fr,pt
  • Fix OPMain home route overwrite.
  • swiss_knife: ^2.3.9
  • mercury_client: ^1.1.4
  • dynamic_call: ^1.0.7
  • intl_messages: ^1.1.6
  • social_login_web: ^1.0.2

1.0.6 #

  • OPSection now is an interface.
  • OPControlledSection
  • bones_ui: ^1.0.5
  • swiss_knife: ^2.3.8

1.0.5 #

  • Better OPMenu behavior.
  • bones_ui: ^1.0.4
  • swiss_knife: ^2.3.7
  • mercury_client: ^1.1.3
  • intl_messages: ^1.1.5
  • social_login_web: ^1.0.1

1.0.4 #

  • OPLoading.topMargin
  • OceanExpressApp.getAccessibleSections()
  • bones_ui: ^1.0.3
  • swiss_knife: ^2.3.5
  • mercury_client: ^1.1.2
  • dynamic_call: ^1.0.6
  • intl_messages: ^1.1.4

1.0.3 #

  • Use CSS prefix 'ui-' for components.
  • bones_ui: ^1.0.2

1.0.2 #

  • Rename OPComponent to OPSection.
  • bones_ui: ^1.0.1

1.0.1 #

  • Fix typo in constant.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ocean_press: ^1.0.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ocean_press/ocean_press.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on ios

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on linux

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on macos

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on windows

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime native

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Package not compatible with runtime native-aot

Because:

  • package:ocean_press/ocean_press.dart that imports:
  • package:ocean_press/src/ocean_press_ui.dart that imports:
  • package:ocean_press/src/ocean_press_sys.dart that imports:
  • package:ocean_press/src/ocean_press_base.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/bones_ui_explorer.dart that imports:
  • package:json_render/json_render.dart that imports:
  • package:json_render/src/json_render_types.dart that imports:
  • package:json_render/src/json_render_base.dart that imports:
  • package:json_render/src/json_render_media.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ocean_press.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
bones_ui ^1.0.12 1.0.12
bones_ui_bootstrap ^1.0.3 1.0.3
dynamic_call ^1.0.10 1.0.10
enum_to_string ^1.0.9 1.0.9
intl_messages ^1.1.8 1.1.8
markdown ^2.1.4 2.1.5
mercury_client ^1.1.8 1.1.8
social_login_web ^1.0.2 1.0.2
swiss_knife ^2.5.3 2.5.4
Transitive dependencies
amdjs 1.0.5
args 1.6.0
charcode 1.1.3
chart_engine 1.1.3
collection 1.14.13 1.15.0-nullsafety
color_palette_generator 1.0.1
csslib 0.16.1
dom_builder 1.0.7
dom_tools 1.3.3
expressions 0.1.5
html 0.14.0+3
html_unescape 1.0.1+3
intl 0.16.1
js 0.6.2
json_object_mapper 1.0.0
json_render 1.3.3
matcher 0.12.8
meta 1.2.2 1.3.0-nullsafety
path 1.7.0
petitparser 3.0.4
quiver 2.1.3
resource_portable 2.1.7
service_worker 0.2.4
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
yaml 2.2.1
Dev dependencies
pedantic ^1.9.0
test ^1.14.7