objectbox_generator 0.7.0

Dart native

ObjectBox binding code generator - finds annotated entities and adds them to the ObjectBox DB model.

1
likes
70 / 110
pub points
50 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 3 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:objectbox_generator/objectbox_generator.dart that imports:
  • package:objectbox_generator/src/code_builder.dart that imports:
  • package:objectbox_generator/src/code_chunks.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/code_builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/code_chunks.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.35.0 <=0.39.140.39.140.40.4
build^1.0.01.5.01.5.0
dart_style^1.3.01.3.61.3.7
glob^1.1.01.2.01.2.0
objectbox0.7.00.7.00.7.0
path^1.6.01.7.01.7.0
source_gen^0.9.00.9.7+10.9.7+1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-6.0.011.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.1.40.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
ffi-0.1.30.1.3
flat_buffers-1.12.01.12.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.35.0 <=0.39.14` on analyzer does not support the latest published version `0.40.4`

pubspec.yaml:16:13

   ╷
16 │   analyzer: ">=0.35.0 <=0.39.14"
   │             ^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
50%
popularity

Publisher

objectbox.io

ObjectBox binding code generator - finds annotated entities and adds them to the ObjectBox DB model.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

analyzer, build, dart_style, glob, objectbox, path, source_gen

More

Packages that depend on objectbox_generator