objectbox_generator 0.6.1

See package ObjectBox.

See ObjectBox changelog.

example/README.md

See ObjectBox example.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  objectbox_generator: ^0.6.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:objectbox_generator/objectbox_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health issues and suggestions

Document public APIs. (-1 points)

3 out of 3 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/code_builder.dart.

Run dartfmt to format lib/src/code_builder.dart.

Format lib/src/code_chunks.dart.

Run dartfmt to format lib/src/code_chunks.dart.

Format lib/src/entity_resolver.dart.

Run dartfmt to format lib/src/entity_resolver.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
analyzer >=0.35.0 <0.100.0 0.39.4
build ^1.0.0 1.2.2
dart_style ^1.3.0 1.3.3
glob ^1.1.0 1.2.0
objectbox 0.6.1 0.6.1
path ^1.6.0 1.6.4
source_gen ^0.9.0 0.9.4+7
Transitive dependencies
_fe_analyzer_shared 1.0.3
args 1.5.2
async 2.4.0
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
ffi 0.1.3
flat_buffers 1.11.0
html 0.14.0+3
js 0.6.1+1
logging 0.11.4
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0 2.0.0
pedantic 1.9.0
pub_semver 1.4.3
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0