nui_media 0.0.2 icon indicating copy to clipboard operation
nui_media: ^0.0.2 copied to clipboard

Flutter package for media actions such as selecting image/video from gallery or taking new photo/video.

1
likes
40/ 130
pub points
58%
popularity

We analyzed this package 2 days ago, and awarded it 40 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis http://dev.g-i.com.my/istudio/docs/core/overview/ was unreachable.

Repository URL doesn't exist.

At the time of the analysis https://neohwei@bitbucket.org/myinglab/flutterstudio.git was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 343 API elements (4.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/component/nui_app.dart that imports:
  • package:nui_core/model/nui_theme.dart that imports:
  • package:nui_core/ui/styling/nui_theme_styling.dart that imports:
  • package:animated_theme_switcher/animated_theme_switcher.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/component/nui_app.dart that imports:
  • package:nui_core/model/nui_theme.dart that imports:
  • package:nui_core/ui/styling/nui_theme_styling.dart that imports:
  • package:animated_theme_switcher/animated_theme_switcher.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/component/nui_app.dart that imports:
  • package:nui_core/model/nui_theme.dart that imports:
  • package:nui_core/ui/styling/nui_theme_styling.dart that imports:
  • package:animated_theme_switcher/animated_theme_switcher.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/component/nui_app.dart that imports:
  • package:nui_core/model/nui_theme.dart that imports:
  • package:nui_core/ui/styling/nui_theme_styling.dart that imports:
  • package:animated_theme_switcher/animated_theme_switcher.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/nui_sharedpref_util.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:nui_media/nui_media.dart that imports:
  • package:nui_media/nui_camera_util.dart that imports:
  • package:nui_media/ui/nui_camera_view.dart that imports:
  • package:nui_core/nui_core.dart that imports:
  • package:nui_core/ui/nui_sharedpref_util.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 63 issues. Showing the first 2:

ERROR: Undefined class 'NUIListActionHandler'.

lib/model/nui_media_list_repo.dart:10:127

   ╷
10 │     registerItem(NUIListItem(entityClass: NUIMediaHorizontalSelection, shadowRadius:4, inflater: (dynamic data, int position, NUIListActionHandler handler) => NUIListItemImageHorizontal(file: data, handler: handler)));
   │                                                                                                                               ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/model/nui_media_list_repo.dart

ERROR: Undefined class 'NUIListActionHandler'.

lib/model/nui_media_list_repo.dart:11:133

   ╷
11 │     registerItem(NUIListItem(entityClass: NUIMediaHorizontalCameraSelection, shadowRadius:4, inflater: (dynamic data, int position, NUIListActionHandler handler) => NUIListItemCameraHorizontal(handler: handler)));
   │                                                                                                                                     ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/model/nui_media_list_repo.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animator^2.0.12.0.23.2.0
better_player^0.0.130.0.610.0.83
cached_network_image^2.2.02.5.13.2.1
camera^0.5.80.5.8+170.9.8+1
flutterflutter0.0.00.0.0
flutter_image_compress^0.7.00.7.01.1.0
flutter_svg^0.18.00.18.11.1.0
flutter_video_compress^0.3.70.3.7+80.3.7+8
holding_gesture^0.0.30.0.31.1.0
image_picker^0.6.6+50.6.7+220.8.5+3
nui_animation^0.0.10.0.20.0.2
nui_core^0.0.10.0.1270.1.1
nui_database^0.0.10.0.30.0.11
pathany1.8.21.8.2
path_provider^1.6.141.6.282.0.11
permission_handler^5.0.15.1.0+210.0.0
photo_manager^0.5.80.5.82.1.4
video_player^0.10.100.10.12+52.4.5
video_thumbnail^0.2.20.2.5+10.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
advance_pdf_viewer-1.2.22.0.1
animated_theme_switcher-1.0.92.0.6
archive-2.0.133.3.0
args-1.6.02.3.1
bloc-6.1.38.0.3
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.11.1.1
collection-1.16.01.16.0
convert-2.1.13.0.2
crypto-2.1.53.0.2
csslib-0.16.20.17.2
cupertino_icons-1.0.51.0.5
device_info-0.4.2+102.0.3
device_info_platform_interface-1.0.12.0.1
ffi-1.2.12.0.1
file-6.1.26.1.2
flutter_bloc-6.1.38.0.1
flutter_blurhash-0.5.00.7.0
flutter_cache_manager-2.1.23.3.0
flutter_markdown-0.2.00.6.10+2
flutter_plugin_android_lifecycle-1.0.112.0.6
flutter_staggered_grid_view-0.3.40.6.1
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.5.2+10.8.5+3
html-0.14.0+40.15.0
html2md-0.3.31.2.6
http-0.12.20.13.4
http_parser-3.1.44.0.1
image-2.1.193.2.0
image_picker_platform_interface-1.1.62.5.0
import_js_library-1.0.21.0.2
infinite_listview-1.1.01.1.0
intl-0.16.10.17.0
js-0.6.40.6.4
line_awesome_flutter-1.0.12.0.0
markdown-2.1.85.0.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
numberpicker-1.3.02.1.1
octo_image-0.3.01.0.2
path_drawing-0.4.1+11.0.0
path_parsing-0.1.41.0.0
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.0
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
petitparser-3.1.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
provider-4.3.36.0.3
pull_to_refresh-1.6.52.0.0
rxdart-0.25.00.27.4
shared_preferences-0.5.12+42.0.15
shared_preferences_linux-0.0.2+42.1.1
shared_preferences_macos-0.0.1+112.0.4
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.1
shimmer-1.1.22.0.0
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
sqflite-1.3.2+42.0.2+1
sqflite_common-1.0.3+32.2.1+1
states_rebuilder-3.2.06.1.0+1
string_scanner-1.1.11.1.1
synchronized-2.2.0+23.0.0+2
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher-5.7.106.1.4
url_launcher_linux-0.0.1+43.0.1
url_launcher_macos-0.0.1+93.0.1
url_launcher_platform_interface-1.0.92.1.0
url_launcher_web-0.1.5+32.0.12
url_launcher_windows-0.0.1+33.0.1
uuid-2.2.23.0.6
vector_math-2.1.22.1.2
video_player_platform_interface-2.2.05.1.3
video_player_web-0.1.4+12.0.10
visibility_detector-0.1.50.3.3
wakelock-0.2.1+10.6.1+2
wakelock_platform_interface-0.1.0+10.3.0
wakelock_web-0.1.0+30.4.0
win32-2.6.12.7.0
workmanager-0.2.40.5.0
xdg_directories-0.1.20.2.0+1
xml-4.5.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 13 issues. Showing the first 2:

The constraint `^2.0.1` on animator does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions animator to update the constraint.

The constraint `^2.2.0` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.2, Dart 2.17.3.

1
likes
40
pub points
58%
popularity

Publisher

unverified uploader

Flutter package for media actions such as selecting image/video from gallery or taking new photo/video.

Homepage (insecure)
Repository (missing)

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

animator, better_player, cached_network_image, camera, flutter, flutter_image_compress, flutter_svg, flutter_video_compress, holding_gesture, image_picker, nui_animation, nui_core, nui_database, path, path_provider, permission_handler, photo_manager, video_player, video_thumbnail

More

Packages that depend on nui_media