nucleoid_built 0.2.4 icon indicating copy to clipboard operation
nucleoid_built: ^0.2.4 copied to clipboard

nucleoid_built package

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 39 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 186 API elements (0.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Missing a corresponding override of 'hashCode'.

lib/model_sql.dart:14:17

   ╷
14 │   bool operator ==(other) => identical(this, other) || other is FieldTypeDart && name == other.name;
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/model_sql.dart

INFO: A value for optional parameter 'size' isn't ever given.

lib/model_sql.dart:35:52

   ╷
35 │   const _FieldTypeBase(this.name, this.type, [this.size]);
   │                                                    ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/model_sql.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build>=0.12.0 <2.0.01.6.32.3.1
meta^1.1.81.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.052.0.0
analyzer-1.7.25.4.0
async-2.10.02.10.0
cli_util-0.3.50.3.5
collection-1.17.11.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
file-6.1.46.1.4
glob-2.1.12.1.1
logging-1.1.11.1.1
package_config-2.1.02.1.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.12.0 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.0.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

nucleoid_built package

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

build, meta

More

Packages that depend on nucleoid_built