nominatim_geocoding 0.0.6 copy "nominatim_geocoding: ^0.0.6" to clipboard
nominatim_geocoding: ^0.0.6 copied to clipboard

A library to forward and reverse geocoding using OSM nominatim API.

7
likes
140/ 160
pub points
84%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

47 out of 47 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.13.0 <3.0.0' don't guarantee it.

lib/src/model/address.dart:105:246

    ╷
105 │     return 'Address(house_number: $houseNumber, road: $road, neighbourhood: $neighbourhood, suburb: $suburb, city: $city, district: $district, state: $state, postcode: $postalCode, country: $country, country_code: $countryCode, locale: ${locale.name.toLowerCase()})';
    │                                                                                                                                                                                                                                                      ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/address.dart

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.13.0 <3.0.0' don't guarantee it.

lib/src/nominatim_provider.dart:54:37

   ╷
54 │           'accept-language': locale.name.toLowerCase(),
   │                                     ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/nominatim_provider.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
get >=4.6.1 <6.0.0 4.6.6 4.6.6
get_storage >=2.0.3 <3.0.0 2.1.1 2.1.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
140
pub points
84%
popularity

Publisher

unverified uploader

A library to forward and reverse geocoding using OSM nominatim API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

equatable, flutter, get, get_storage

More

Packages that depend on nominatim_geocoding