nhost_sdk 5.3.0 copy "nhost_sdk: ^5.3.0" to clipboard
nhost_sdk: ^5.3.0 copied to clipboard

Nhost authentication and file storage/retrieval APIs for the Dart language.

23
likes
130/ 140
pub points
73%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/nhost/nhost-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

43 out of 166 API elements (25.9 %) have documentation comments.

Some symbols that are missing documentation: nhost_sdk, nhost_sdk.ApiClient.baseUrl, nhost_sdk.ApiClient.send, nhost_sdk.ApiException.body, nhost_sdk.ApiException.request.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^1.1.0 1.2.1 1.2.1
http_parser ^4.0.1 4.0.2 4.0.2
jwt_decoder ^2.0.1 2.0.1 2.0.1
logging ^1.1.0 1.2.0 1.2.0
meta ^1.7.0 1.14.0 1.14.0
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

23
likes
130
pub points
73%
popularity

Publisher

verified publishernhost.io

Nhost authentication and file storage/retrieval APIs for the Dart language.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, http_parser, jwt_decoder, logging, meta, path

More

Packages that depend on nhost_sdk