nhost_flutter_auth 4.0.4 copy "nhost_flutter_auth: ^4.0.4" to clipboard
nhost_flutter_auth: ^4.0.4 copied to clipboard

Provides Nhost authentication state to your Flutter app, making it easy to set up protected resources, and react to sign ins and sign outs.

11
likes
120/ 140
pub points
74%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/nhost/nhost-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

86 out of 109 API elements (78.9 %) have documentation comments.

Some symbols that are missing documentation: nhost_flutter_auth, nhost_flutter_auth.ApiException.body, nhost_flutter_auth.ApiException.request, nhost_flutter_auth.ApiException.response, nhost_flutter_auth.ApiException.responseBody.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/provider.dart:55:17

   ╷
55 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/provider.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
nhost_dart ^2.0.4 2.0.4 2.0.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
gql - 1.0.1-alpha+1709845491443 1.0.1-alpha+1709845491443
gql_dedupe_link - 2.0.4-alpha+1709845491527 2.0.4-alpha+1709845491527
gql_error_link - 1.0.0+1 1.0.0+1
gql_exec - 1.1.1-alpha+1699813812660 1.1.1-alpha+1699813812660
gql_http_link - 1.0.1+1 1.0.1+1
gql_link - 1.0.1-alpha+1709845491457 1.0.1-alpha+1709845491457
gql_transform_link - 1.0.0 1.0.0
gql_websocket_link - 2.0.1 2.0.1
graphql - 5.2.0-beta.7 5.2.0-beta.7
hive - 2.2.3 2.2.3
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
jwt_decoder - 2.0.1 2.0.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nhost_auth_dart - 2.2.0 2.2.0
nhost_functions_dart - 2.0.4 2.0.4
nhost_gql_links - 4.0.5 4.0.5
nhost_graphql_adapter - 4.0.4 4.0.4
nhost_sdk - 5.3.0 5.3.0
nhost_storage_dart - 2.0.4 2.0.4
normalize - 0.8.2+1 0.9.1
path - 1.9.0 1.9.0
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

11
likes
120
pub points
74%
popularity

Publisher

verified publishernhost.io

Provides Nhost authentication state to your Flutter app, making it easy to set up protected resources, and react to sign ins and sign outs.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, nhost_dart

More

Packages that depend on nhost_flutter_auth