nhost_dart 2.0.4 copy "nhost_dart: ^2.0.4" to clipboard
nhost_dart: ^2.0.4 copied to clipboard

Nhost Dart SDK

11
likes
130/ 140
pub points
70%
popularity

We analyzed this package 20 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/nhost/nhost-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: nhost_dart,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has multiple matching pubspec.yaml with name: nhost_dart.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

84 out of 106 API elements (79.2 %) have documentation comments.

Some symbols that are missing documentation: nhost_dart, nhost_dart.ApiException.body, nhost_dart.ApiException.request, nhost_dart.ApiException.response, nhost_dart.ApiException.responseBody.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^1.1.0 1.2.1 1.2.1
http_parser ^4.0.1 4.0.2 4.0.2
logging ^1.1.0 1.2.0 1.2.0
meta ^1.7.0 1.14.0 1.14.0
nhost_auth_dart ^2.2.0 2.2.0 2.2.0
nhost_functions_dart ^2.0.4 2.0.4 2.0.4
nhost_graphql_adapter ^4.0.4 4.0.4 4.0.4
nhost_sdk ^5.3.0 5.3.0 5.3.0
nhost_storage_dart ^2.0.4 2.0.4 2.0.4
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
gql - 1.0.1-alpha+1709845491443 1.0.1-alpha+1709845491443
gql_dedupe_link - 2.0.4-alpha+1709845491527 2.0.4-alpha+1709845491527
gql_error_link - 1.0.0+1 1.0.0+1
gql_exec - 1.1.1-alpha+1699813812660 1.1.1-alpha+1699813812660
gql_http_link - 1.0.1+1 1.0.1+1
gql_link - 1.0.1-alpha+1709845491457 1.0.1-alpha+1709845491457
gql_transform_link - 1.0.0 1.0.0
gql_websocket_link - 2.0.1 2.0.1
graphql - 5.2.0-beta.7 5.2.0-beta.7
hive - 2.2.3 2.2.3
jwt_decoder - 2.0.1 2.0.1
nhost_gql_links - 4.0.5 4.0.5
normalize - 0.8.2+1 0.9.1
rxdart - 0.27.7 0.27.7
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.