nacl_win 0.1.0 copy "nacl_win: ^0.1.0" to clipboard
nacl_win: ^0.1.0 copied to clipboard

A flutter plugin for Windows for generating Ed25519 keys and signing messages.

0
likes
110/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: EUPL-1.2.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

20 out of 70 API elements (28.6 %) have documentation comments.

Some symbols that are missing documentation: bridge_generated, bridge_generated.DartPort, bridge_generated.DartPostCObjectFnType, bridge_generated.EdKeyPair, bridge_generated.EdKeyPair.EdKeyPair.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:nacl_win/nacl_win.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:nacl_win/nacl_win.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:nacl_win/nacl_win.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:nacl_win/nacl_win.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:nacl_win/nacl_win.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The named parameter 'parseErrorData' is required, but there's no corresponding argument.

lib/bridge_generated.dart:43:36

   ╷
43 │     return _platform.executeNormal(FlutterRustBridgeTask(
   │                                    ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bridge_generated.dart

ERROR: The named parameter 'parseErrorData' is required, but there's no corresponding argument.

lib/bridge_generated.dart:62:36

   ╷
62 │     return _platform.executeNormal(FlutterRustBridgeTask(
   │                                    ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bridge_generated.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_rust_bridge ^1.70.1 1.82.6 1.82.6
meta ^1.8.0 1.12.0 1.15.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build_cli_annotations - 2.1.0 2.1.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pool - 1.5.1 1.5.1
puppeteer - 3.11.0 3.11.0
shelf - 1.4.1 1.4.1
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
110
pub points
0%
popularity

Publisher

verified publisherhumancolossus.org

A flutter plugin for Windows for generating Ed25519 keys and signing messages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

EUPL-1.2 (LICENSE)

Dependencies

ffi, flutter, flutter_rust_bridge, meta, plugin_platform_interface

More

Packages that depend on nacl_win