my_search_plugin 0.0.1 icon indicating copy to clipboard operation
my_search_plugin: ^0.0.1 copied to clipboard

A new Flutter project.

2
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/Socian-Ltd/-my-search-plugin-flutter was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 49 out of 107 API elements (45.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:my_search_plugin/my_search_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:my_search_plugin/my_search_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:my_search_plugin/my_search_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:my_search_plugin/my_search_plugin.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 76 issues. Showing the first 2:

ERROR: The named parameter 'maxLengthEnforced' isn't defined.

lib/my_search_plugin.dart:515:13

    ╷
515 │             maxLengthEnforced: widget.textFieldConfiguration.maxLengthEnforced,
    │             ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/my_search_plugin.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/my_search_plugin.dart:289:28

    ╷
289 │     WidgetsBinding.instance!.removeObserver(this);
    │                            ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/my_search_plugin.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_keyboard_visibility^5.0.05.4.05.4.0
http^0.13.40.13.50.13.5
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.17.01.17.1
flutter_keyboard_visibility_linux-1.0.01.0.0
flutter_keyboard_visibility_macos-1.0.01.0.0
flutter_keyboard_visibility_platform_interface-2.0.02.0.0
flutter_keyboard_visibility_web-2.0.02.0.0
flutter_keyboard_visibility_windows-1.0.01.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.24.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.