multipack 0.1.2
multipack: ^0.1.2 copied to clipboard

A tool for monorepo management. Link local packages and execute commands in topological order.

9
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Nov 9, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 81 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:multipack/commands.dart that imports:
  • package:multipack/commands/pubspec.dart that imports:
  • package:multipack/package.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.12.0.1
args^1.6.01.6.02.3.0
directed_graph^0.1.20.1.90.3.5
meta^1.0.01.7.01.7.0
path^1.6.41.8.01.8.0
pub_semver^1.4.41.4.42.1.0
pubspec^0.1.20.1.52.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
graphs-0.2.02.1.0
lazy_evaluation-0.0.6+31.1.0
matcher-0.12.110.12.11
quiver-2.1.53.0.1+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
uri-0.11.41.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.0.2` on ansicolor does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

9
likes
70
pub points
0%
popularity

Publisher

gql-dart.dev

A tool for monorepo management. Link local packages and execute commands in topological order.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, directed_graph, meta, path, pub_semver, pubspec

More

Packages that depend on multipack