multi_instance_handler 1.0.0 copy "multi_instance_handler: ^1.0.0" to clipboard
multi_instance_handler: ^1.0.0 copied to clipboard

Detect and handle multiple instances of an application.

5
likes
70/ 140
pub points
1%
popularity

We analyzed this package 3 days ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 3 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:multi_instance_handler/multi_instance_handler.dart that imports:
  • package:multi_instance_handler/src/api.dart that imports:
  • package:multi_instance_handler/src/controller.dart that imports:
  • package:multi_instance_handler/src/controller_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:multi_instance_handler/multi_instance_handler.dart that imports:
  • package:multi_instance_handler/src/api.dart that imports:
  • package:multi_instance_handler/src/controller.dart that imports:
  • package:multi_instance_handler/src/controller_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:multi_instance_handler/multi_instance_handler.dart that imports:
  • package:multi_instance_handler/src/api.dart that imports:
  • package:multi_instance_handler/src/controller.dart that imports:
  • package:multi_instance_handler/src/controller_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:multi_instance_handler/multi_instance_handler.dart that imports:
  • package:multi_instance_handler/src/api.dart that imports:
  • package:multi_instance_handler/src/controller.dart that imports:
  • package:multi_instance_handler/src/controller_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:multi_instance_handler/multi_instance_handler.dart that imports:
  • package:multi_instance_handler/src/api.dart that imports:
  • package:multi_instance_handler/src/controller.dart that imports:
  • package:multi_instance_handler/src/controller_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The method 'setMockMethodCallHandler' isn't defined for the type 'MethodChannel'.

lib/src/controller.dart:56:13

   ╷
56 │     channel.setMockMethodCallHandler((call) async {
   │             ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

WARNING: Braces unnecessarily wrap this expression in a set literal.

lib/src/controller_windows.dart:119:25

    ╷
119 │       ..listen((msg) => {if (msg is int) _readPipe(writer, msg)});
    │                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller_windows.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.0.0 1.2.1 2.1.2
flutter flutter 0.0.0 0.0.0
shared_preferences ^2.0.5 2.2.3 2.2.3
uuid ^3.0.0 3.0.7 4.4.0
win32 ^2.0.5 2.6.1 5.5.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.0.7 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^3.0.0` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

5
likes
70
pub points
1%
popularity

Publisher

verified publisherloren.dev

Detect and handle multiple instances of an application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter, shared_preferences, uuid, win32

More

Packages that depend on multi_instance_handler