ms_persist 2.0.0
ms_persist: ^2.0.0 copied to clipboard

A mixin that help you on handling model as a CRUD, you just need implement 3 overrides

6
likes
110/ 130
pub points
0%
popularity

We analyzed this package 34 hours ago, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 15 API elements (93.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:ms_persist/ms_persist.dart that imports:
  • package:ms_persist/src/persist.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.4.

    Because mockito <3.0.0-beta+3 requires SDK version >=1.0.0 <2.0.0-∞ and mockito >=3.0.0-beta+3 <3.0.1 depends on test ^1.2.0, mockito <3.0.1 requires test ^1.2.0.
    And because mockito >=3.0.1 <3.0.2 depends on test_api ^0.1.1, mockito <3.0.2 requires test_api ^0.1.1 or test ^1.2.0.
    And because mockito >=5.0.12 <5.0.16 depends on analyzer >=1.0.0 <3.0.0 and mockito >=5.0.0 <5.0.12 depends on analyzer ^1.0.0, mockito <3.0.2-∞ or >=5.0.0 <5.0.16-∞ requires test_api ^0.1.1 [...]
    And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito <3.0.2-∞ or >=4.1.1+1 <5.0.16-[...]
(1) So, because mockito >=4.0.0 <=4.1.1 depends on test_api ^0.2.1 and mockito ^3.0.2 depends on test ^1.2.0, mockito <5.0.16 requires test_api ^0.1.1 or >=0.2.1 <0.4.0 or test ^1.2.0 or analyzer[...]

    Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.[...]
    And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1[...]
[11 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

6
likes
110
pub points
0%
popularity

Publisher

marcussoftware.info

A mixin that help you on handling model as a CRUD, you just need implement 3 overrides

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ms_map_utils, path, path_provider, sembast, sembast_sqflite, sqflite, uuid

More

Packages that depend on ms_persist