mpp 1.0.2+1
mpp: ^1.0.2+1 copied to clipboard

Git-based, password-protected, open-source, standalone private Pub server.

2
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 63 API elements (20.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mpp/mpp.dart that imports:
  • package:mpp/src/routes/routes.dart that imports:
  • package:mpp/src/routes/controllers/controllers.dart that imports:
  • package:mpp/src/routes/controllers/pub.dart that imports:
  • package:pubspec/pubspec.dart that imports:
  • package:pubspec/src/pubspec.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

bin/mpp.dart:54:7

   ╷
54 │       throw ArgParserException('Missing required `username` option.');
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/mpp.dart

INFO: DO use curly braces for all flow control structures.

bin/mpp.dart:56:7

   ╷
56 │       throw ArgParserException('Missing required `password` option.');
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/mpp.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_auth^2.0.02.1.5+12.1.5+1
angel_configuration^2.0.02.2.02.2.0
angel_container^1.0.01.1.01.1.0
angel_file_service^2.0.02.0.12.0.1
angel_framework^2.0.0-rc.02.1.12.1.1
angel_hot^2.0.02.0.62.0.6
angel_http_exception^1.0.01.1.01.1.0
angel_production^1.0.0-alpha1.0.01.0.0
angel_serialize^2.0.02.2.3+32.2.3+3
archive^2.0.02.0.133.1.2
args^1.0.01.6.02.1.0
dbcrypt^1.0.01.0.02.0.0
file^5.0.05.2.16.1.0
http_parser^3.0.03.1.44.0.0
io^0.3.20.3.51.0.0
logging^0.11.00.11.41.0.1
path^1.0.01.8.01.8.0
pub_semver^1.0.01.4.42.0.0
pubspec^0.1.10.1.52.0.1
tuple^1.0.01.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_client-2.0.22.0.2
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
angel_websocket-2.0.32.0.3
async-2.6.12.6.1
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
dotenv-1.0.02.0.0
glob-1.2.02.0.1
html_builder-1.0.51.0.5
http-0.12.20.13.3
http2-1.0.12.0.0
http_server-0.9.8+31.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_god-2.0.0-beta+32.0.0-beta+3
json_rpc_2-2.2.23.0.1
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
pool-1.5.01.5.0
pub_sub-2.3.02.3.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
recase-2.0.14.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.4
vm_service_lib-0.3.10+23.22.2+1
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^2.0.0` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `^1.0.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.