mops_wallet_core 0.0.1 copy "mops_wallet_core: ^0.0.1" to clipboard
mops_wallet_core: ^0.0.1 copied to clipboard

Mops Wallet Core for Flutter.

1
likes
120/ 160
pub points
49%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 78 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: mops_wallet_core, mops_wallet_core.WalletCreate, mops_wallet_core.WalletCreate.WalletCreate, mops_wallet_core.WalletCreate.createWallet, mops_wallet_core.WalletCreate.getWallet.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:mops_wallet_core/mops_wallet_core.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:mops_wallet_core/mops_wallet_core.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:mops_wallet_core/mops_wallet_core.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/controller/wallet_create_controller.dart:1:1

  ╷
1 │ part of mops_wallet_core;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/controller/wallet_create_controller.dart

INFO: The part-of directive uses a library name.

lib/database/wallet_database.dart:1:1

  ╷
1 │ part of mops_wallet_core;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/database/wallet_database.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bip32 ^2.0.0 2.0.0 2.0.0
bip39 ^1.0.6 1.0.6 1.0.6
coinslib ^3.1.7 3.1.8 3.1.8
dart_bip32_bip44 ^0.2.0 0.2.0 0.2.0
ed25519_hd_key ^2.2.0 2.2.1 2.2.1
eip55 ^1.0.2 1.0.2 1.0.2
flutter flutter 0.0.0 0.0.0
hex ^0.2.0 0.2.0 0.2.0
path ^1.8.1 1.9.0 1.9.0
sqflite ^2.0.3+1 2.3.3+1 2.3.3+1
web3dart ^2.3.5 2.7.3 2.7.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
base58check - 2.0.0 2.0.0
bs58check - 1.0.2 1.0.2
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
eip1559 - 0.6.2 0.6.2
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
js - 0.7.1 0.7.1
json_rpc_2 - 3.0.2 3.0.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
pinenacl - 0.5.1 0.6.0
pointycastle - 3.9.1 3.9.1
sec - 1.1.0 1.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite_common - 2.5.4 2.5.4
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.3.0 1.3.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
wallet - 0.0.13 0.0.13
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.