moor_generator 4.2.2
moor_generator: ^4.2.2 copied to clipboard

Dev-dependency to generate table and dataclasses together with the moor package.

32
likes
80 / 130
pub points
92 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 247 out of 520 API elements (47.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:moor_generator/moor_generator.dart that imports:
  • package:moor_generator/src/model/model.dart that imports:
  • package:moor_generator/src/model/view.dart that imports:
  • package:moor_generator/src/model/declarations/declaration.dart that imports:
  • package:moor_generator/src/model/sources.dart that imports:
  • package:moor_generator/src/analyzer/runner/file_graph.dart that imports:
  • package:moor_generator/src/analyzer/errors.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'modules' is deprecated and shouldn't be used. Use effectiveModules instead.

lib/src/analyzer/options.dart:134:42

    ╷
134 │     if (sqliteAnalysisOptions != null && modules.isNotEmpty) {
    │                                          ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/analyzer/options.dart

INFO: 'modules' is deprecated and shouldn't be used. Use effectiveModules instead.

lib/src/analyzer/options.dart:136:9

    ╷
136 │         modules,
    │         ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/analyzer/options.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.1.01.5.01.5.0
analyzer_plugin_fork^0.5.00.5.10.5.1
args>=1.5.0 <3.0.02.1.02.1.0
build^2.0.02.0.12.0.1
build_config>=0.3.1 <2.0.01.0.01.0.0
build_resolvers^2.0.02.0.12.0.1
charcode^1.2.01.2.01.2.0
cli_util>=0.2.0 <0.4.00.3.00.3.0
collection^1.14.01.15.01.15.0
dart_style>=1.3.3 <3.0.02.0.02.0.0
json_annotation^4.0.04.0.14.0.1
logging>=0.11.0 <2.0.01.0.11.0.1
meta^1.1.01.3.01.3.0
moor^4.1.04.2.14.2.1
path^1.6.01.8.01.8.0
recase>=2.0.1 <5.0.04.0.04.0.0
source_gen>=0.9.4 <2.0.01.0.01.0.0
source_span^1.5.51.8.11.8.1
sqlite3>=0.1.6 <2.0.01.0.01.0.0
sqlparser^0.15.00.15.00.15.0
stream_transform>=0.1.0 <3.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-21.0.021.0.0
async-2.5.02.5.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
glob-2.0.12.0.1
graphs-2.0.02.0.0
package_config-2.0.02.0.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pubspec_parse-1.0.01.0.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • moor_generator that depends on:
  • analyzer_plugin_fork that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.2.