mongol 7.0.0 copy "mongol: ^7.0.0" to clipboard
mongol: ^7.0.0 copied to clipboard

Flutter widget package for displaying and editing vertical Mongolian text.

56
likes
85/ 140
pub points
84%
popularity

We analyzed this package 9 hours ago, and awarded it 85 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:63:5

   ╷
63 │ <li><a href="http://www.mongolfont.com/en/font/index.html">MongolFont</a></li>
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

528 out of 553 API elements (95.5 %) have documentation comments.

Some symbols that are missing documentation: mongol, mongol.HorizontalCaretMovementRun.movePrevious, mongol.MongolAlertDialog.actions, mongol.MongolAlertDialog.actionsOverflowDirection, mongol.MongolAlertDialog.actionsPadding.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

ERROR: The method 'isSelectionWithinTextBounds' isn't defined for the type 'TextEditingController'.

lib/src/editing/mongol_editable_text.dart:2505:28

     ╷
2505 │     if (!widget.controller.isSelectionWithinTextBounds(selection)) return;
     │                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/editing/mongol_editable_text.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/base/mongol_paragraph.dart:891:17

    ╷
891 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/base/mongol_paragraph.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
characters ^1.2.1 1.3.0 1.3.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

56
likes
85
pub points
84%
popularity
screenshot

Publisher

verified publishersuragch.dev

Flutter widget package for displaying and editing vertical Mongolian text.

Repository (GitHub)
View/report issues

Topics

#text

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

characters, flutter

More

Packages that depend on mongol