mongo_database 1.0.0-dev.0
mongo_database: ^1.0.0-dev.0 copied to clipboard

A wrap of the mongo database to be compatible with the database_interface

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.com/rushio-consulting/mongo_database was unreachable.

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 15 API elements (40.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mongo_database/mongo_database.dart that imports:
  • package:mongo_database/src/db.dart that imports:
  • package:mongo_database/src/collection.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
database_interface^1.0.0-dev.01.0.0-dev.01.0.0-dev.0
mongo_dart^0.3.30.3.60.7.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bson-0.3.41.0.4
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
conn_pool-2.1.92.1.9
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
logging-0.11.41.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mongo_dart_query-0.3.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
pool-1.5.01.5.0
quiver-2.1.53.0.1+1
rational-0.3.82.0.0
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.3` on mongo_dart does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions mongo_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
60
pub points
0%
popularity

A wrap of the mongo database to be compatible with the database_interface

Repository (missing)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

database_interface, mongo_dart

More

Packages that depend on mongo_database